I decided to put this here just as much as a reminder to myself as for the benefit of others. :-)

Every time I'm setting up a Raspberry Pi and I want to connect it to my VPN, I run in to this issue. Everything works, WLAN is set up and working, I add my OpenVPN config and... the WiFi on my Raspberry Pi dies.

Here's the solution. Edit the file /etc/default/ifplugd and change this line:

HOTPLUG_INTERFACES="all"

to this:

HOTPLUG_INTERFACES="eth0 wlan0"

It seems that when set to Raspbian's default "all", the hotplug system tries to manage the VPNs tun0 device, which causes trouble.

This blog post was posted to Techie Brain Showers on Tuesday January 13th, 2015 at 11:38AM
 

2 Responses to "OpenVPN over WLAN on Raspbian"

  • October 30th, 2015, 6:26 p.m.

    Checking that out ...

    I get no address this way!

  • October 30th, 2015, 6:50 p.m.

    Correction on previous comment:

    I made a mistake in wpa_supplicant.conf . Therefore could not connect to wlan anymore .

    Works with vpn now after changing ihotplug_interfaces eth0 wlan0 as described

    Thx!!

Leave a Comment

You can use bbcode in the comment: e.g. [b]This is bold[/b], [url]http://www.achanceofbrainshowers.com[/url], [code python]import this[/code]
Preview Posting...
Previewing comment, please wait a moment...

My name is Patrick Van Oosterwijck. Welcome to my spot on the web where I will hopefully regularly dump some of my brain content for the benefit of whomever may find it useful.

Search for Posts
Possibly related posts
Tags
Popular Tags
 
Archives
2016
 
 
© 2010 Patrick Van Oosterwijck.

Using technoblog blog engine by Will McGugan